Lyo 4.0 JDK11+ support


#1
  • Stay on JDK 8
  • Move to JDK 11 and keep source/binary compat at ‘1.8’
  • Move to JDK 11 and use Java 11 features

0 voters

See the discussion here: https://www.eclipse.org/lists/lyo-dev/msg01092.html


#2

NB! https://blog.joda.org/2018/03/jpms-negative-benefits.html This mostly applies to Lyo, the rest of you can use Lyo in your apps running JDK 11+ https://blog.joda.org/2018/09/from-java-8-to-java-11.html